Learn Japanese with JapanesePod101.com

View topic - Known Issues (thanks to Coco!)

Known Issues (thanks to Coco!)

Spotted any errors or found anything that doesn't work?

Known Issues (thanks to Coco!)

Postby clay » Thu 02.28.2008 4:09 pm

1) Forum Private Messages - This should work now. Oni just sent me a message, but let me know if you can't use yours. Right now the site has two separate PM systems, so I'm guessing we'll ax the Drupal one. But we'll keep both for now.
2) can't log in to the forum - I've posted a few ideas on the front page. It seems most of these problems have gone away in time. Any other ideas?
3) no backed up ID - This is referring to the users who signed up while the old site had a red banner last week. (sorry it took so long!) I'm afraid you will have to signup again. HOWEVER, you can easily copy and paste any posts from the old site by going to http://old.thejapanesepage.com.
4)文字化け - in the shoutbox. Yes, this is a small problem. It is either mojibake or let the column get really whacked out if someone posts a long word like a URL. I added a line in the code to cut long words (like URL) in half, but it also breaks Japanese often. Not sure what to do here.
5)Twins? - Try logging out, request new password as original username and change password.
6) re-log in "I have to re login in order to post, what could be the problem? " I'm not sure... Anyone else have this problem?
7) newest threads column - I would like to add a newest threads column on the front page soon. See below
8) layout See below
9) 500error I think there will be good news on this soon. 1and1 did some work on the server today (that is why it was down.) I still haven't gotten their report yet, but the site seems to be better. If I don't hear from them in the next few hours, I'll call again.
10)Timestamp  It was suggested to change the timestamp to something similar to the old site. I did that, but I think you can update it in your user control panel. Let me know what you think is best.
11) Delete Forum posts I *think* I fixed this. Please let me know.
12) Blank white page - this happens when someone isn't logged into phpBB and clicks on the 'login' link at the top right of the forums. The problem goes back to #2 above which hopefully will be resolved in time. I need to hide that link to prevent confusion.


Some of these problems will be solved when phpBB gets its theme. My goal (I don't know if it is possible) is for phpBB to look like the rest of the site with a right and left column. If not, it will at least have a left column with some Drupal blocks like Shoutbox, menu bar and who's online. I will know more after hiring the developer. I will also figure a way to get a newest threads column in drupal.
TheJapanShop.com- Japanese language learning materials
Checkout our iPhone apps: TheJapanesePage.com/iPhone
User avatar
clay
Site Admin
 
Posts: 2809
Joined: Fri 01.21.2005 9:39 am
Location: Florida

Re: Known Issues (thanks to Coco!)

Postby AJBryant » Thu 02.28.2008 9:35 pm

clay wrote:6) re-log in "I have to re login in order to post, what could be the problem? " I'm not sure... Anyone else have this problem?


This is happening to me. Every time I come back to the forum (after leaving it) I have to re-log in. I imagine this is what the issue is talking about.


Tony
User avatar
AJBryant
Site Admin
 
Posts: 5313
Joined: Sun 10.09.2005 11:29 am
Location: Indiana
Native language: English
Gender: Male

Re: Known Issues (thanks to Coco!)

Postby Axlen » Thu 02.28.2008 10:00 pm

I have a temporary fix for item 4, long lines breaking layout in the Shout Box. You can remove you code that chops the line and instead add a style element "overflow: auto; "to the "div.shoutbox.odd" and "div.shoutbox-odd" entries in the sboutbox.css. This adds a horizontal scrollbar when long text is encountered.

[Edit: Axlen] Japanese characters will wrap normally as soon as you remove the php code that adds spaces every 14 characters. The problem with that approach is that UTF-8 is a variable length character code and I don't think the standard string length function in php is UTF-8 aware. So when spaces are inserted they are sometimes being inserted in places that breaks the character encoding. Thus the strange characters that appear in Japanese text. There are functions that can be used to break the strings at the appropriate places in the string. I'll do some research and come up with a fix for the shoutbox.

ImageImage

Code: Select all
div.shoutbox-even {
  color : #000000;
  padding: 2px;
  background-color : #eee;
  width: 100%;
  overflow: auto;
}

div.shoutbox-odd {
  color : #000000;
  padding: 2px;
  background-color : #fff;
  width: 100%;
  overflow: auto;
}


Regards,
Axlen
Attachments
shoutboxafter.PNG
Shoutbox after
shoutboxafter.PNG (15.9 KiB) Viewed 1633 times
shoutboxbefore.PNG
Shoutbox before
shoutboxbefore.PNG (14.67 KiB) Viewed 1634 times
Last edited by Axlen on Fri 02.29.2008 8:15 pm, edited 1 time in total.
User avatar
Axlen
 
Posts: 52
Joined: Thu 07.20.2006 10:53 pm
Location: Milwaukee

Re: Known Issues (thanks to Coco!)

Postby Valatunda » Fri 02.29.2008 4:44 am

10)Timestamp  It was suggested to change the timestamp to something similar to the old site. I did that, but I think you can update it in your user control panel. Let me know what you think is best.


I prefer the day, month name and year myself. Though I think it should be optional. If the option isn't available from the list, maybe you could post the right codes or what is needed for other settings?
User avatar
Valatunda
 
Posts: 171
Joined: Thu 01.04.2007 6:44 am
Location: イギリス
Native language: 英語

Another Issue

Postby EvanT » Fri 02.29.2008 5:39 am

Here's another interesting discrepancy, Clay. I was logged on to the site for more than an hour (browsing other sites etc.) and I was automatically logged out of the forum (probably due to inactivity), but NOT the main site, so I had to relog-in the forum alone. The problem was that I wasn't presented with a log-in link on the main forum page at that time, until I tried to post a reply in a sub-forum (where I was asked to log in). It's not a world-shaking issue, but it's there nonetheless and I though you should know about it.
EvanT
 
Posts: 80
Joined: Sun 09.23.2007 8:53 am
Location: テサロニキ、希臘

Re: Known Issues (thanks to Coco!)

Postby sei » Fri 02.29.2008 11:59 am

Not sure if you already know about this Clay, or if it's just happening to me. Whenever I go to the edit avatar tab in the User control panel, to add an avatar, it gives me a general error. And doesn't let me do anything. Says something about contacting board admins. I'll edit in a moment...

Edit: This is the error.

General Error
SQL ERROR [ mysql4 ]

Table 'db230384954.drupal_users' doesn't exist [1146]

An SQL error occurred while fetching this page. Please contact the Board Administrator if this problem persists.

Please notify the board administrator or webmaster: clay@thejapanesepage.com
Image
Questions? Feel free to ask. :)
User avatar
sei
 
Posts: 525
Joined: Fri 03.30.2007 3:34 pm
Location: Portugal
Native language: Portuguese
Gender: Female

Re: Known Issues (thanks to Coco!)

Postby Wakannai » Fri 02.29.2008 6:25 pm

Since even clearing the cache wouldn't autolog me into the forum and there is no LOGIN link on the forum page anymore--there is also no logout link-- I was able to do this workaround.

Click on new post, login and check the autolog box. Then hit the back button until I get back to the root page and refresh.

Dunno how long this workaround will last. Even with this workaround, there is no "Welcome Wakannai" or other such login-confirmation at the forum root page. The only confimation that I have a sucessful login now is the "view unanswered posts" link, which is not available if not logged in.
Wakannai
 
Posts: 658
Joined: Thu 10.18.2007 6:38 am

Re: Known Issues (thanks to Coco!)

Postby clay » Fri 02.29.2008 7:03 pm

Sorry! I didn't realize the login (in the forums) was that important. I will add it to the forums again Saturday night. I'm afraid I will be away until then. In fact, I have to run now...

Sorry again for all these troubles. I hope the new server will help with a lot of it. If not, I'll hire people who can fix it for good ASAP.
TheJapanShop.com- Japanese language learning materials
Checkout our iPhone apps: TheJapanesePage.com/iPhone
User avatar
clay
Site Admin
 
Posts: 2809
Joined: Fri 01.21.2005 9:39 am
Location: Florida

Re: Known Issues (thanks to Coco!)

Postby Yudan Taiteki » Mon 03.03.2008 10:05 am

I'm having a lot of trouble with getting "board is down" messages; TJP is nearly unusable for me although I have managed to get through a few times and post (after numerous "board is down" messages during the process).
-Chris Kern
User avatar
Yudan Taiteki
 
Posts: 5609
Joined: Wed 11.01.2006 11:32 pm
Native language: English

Re: Known Issues (thanks to Coco!)

Postby AJBryant » Mon 03.03.2008 3:24 pm

Ditto
User avatar
AJBryant
Site Admin
 
Posts: 5313
Joined: Sun 10.09.2005 11:29 am
Location: Indiana
Native language: English
Gender: Male

Re: Known Issues (thanks to Coco!)

Postby richvh » Mon 03.03.2008 3:55 pm

Hopefully that will be fixed with the move to Rapidserve.
Richard VanHouten
ゆきの物語
richvh
 
Posts: 6451
Joined: Thu 09.29.2005 10:35 pm

Re: Known Issues (thanks to Coco!)

Postby jumika » Wed 03.05.2008 2:27 am

heh i am having kinda some problem with a var/varhost someting? anyone know what this is?

/var/www/vhosts/thejapanesepage.com/httpdocs/phpfreechat/src/../data/private is not writeable
/var/www/vhosts/thejapanesepage.com/httpdocs/phpfreechat/src/../data/private/cache is not writeable
/var/www/vhosts/thejapanesepage.com/httpdocs/phpfreechat/src/../data/private/chat is not writeable
/var/www/vhosts/thejapanesepage.com/httpdocs/phpfreechat/src/../data/private/chat/s_9b57a9a4d4753a73bbe6fea70e13c9a3 can't be created
/var/www/vhosts/thejapanesepage.com/httpdocs/phpfreechat/src/../data/private/chat/s_9b57a9a4d4753a73bbe6fea70e13c9a3 is not writeable
/var/www/vhosts/thejapanesepage.com/httpdocs/phpfreechat/src/../data/private/chat/s_9b57a9a4d4753a73bbe6fea70e13c9a3 is not readable


somethings like that err is this my comp? also is this the reason i cannot join anychat_? even thoug yesterday i could? :oops:
jumika
 
Posts: 2
Joined: Fri 02.29.2008 2:58 am

Re: Known Issues (thanks to Coco!)

Postby coco » Wed 03.05.2008 12:14 pm

2) can't log in to the forum - I've posted a few ideas on the front page. It seems most of these problems have gone away in time. Any other ideas?


FAQ says
If you are having login or logout problems, deleting board cookies may help.
coco
 
Posts: 3061
Joined: Mon 05.30.2005 12:43 am
Location: 東京都
Native language: 日本語(Japanese)

Re: Known Issues (thanks to Coco!)

Postby claytest1 » Wed 03.05.2008 1:07 pm

@jumika --thanks! I was wondering why the flashchat wasn't working. I'll fix that as soon as I get home.

@Axlen-- thanks!! I saw that post a few days ago, but totally forgot to do that with all the excitement. I have emailed myself the info and will get to it as soon as I get home.

(clay logged in as a test account)
claytest1
 
Posts: 1
Joined: Wed 03.05.2008 1:04 pm

Re: Known Issues (thanks to Coco!)

Postby fielle » Wed 03.05.2008 8:13 pm

It seems that I can successfully log on at home but not at work (where I'm behind a proxy, if that makes a difference).

At work I may be listed in the "online" list, but there's still the login dialog right above it, and generally otherwise shows symptoms of not being logged in. I cleared my cookies multiple times and everything.

I'm using firefox on both computers, although home is vista and work is xp.
User avatar
fielle
 
Posts: 163
Joined: Thu 02.28.2008 3:24 pm
Native language: English
Gender: Female

Next

Return to Problems

Who is online

Users browsing this forum: No registered users and 1 guest