Learn Japanese with JapanesePod101.com

View topic - IME won't change input mode

IME won't change input mode

Japanese, general discussion on the language

IME won't change input mode

Postby Pete D » Sun 11.04.2007 8:56 pm

I finally found my WinXP CD and installed the Japanese IME following the instructions at http://greggman.com/japan/xp-ime/xp-ime.htm. I can now flip back and forth between JP and EN language modes at will, and the language bar is set up all neatly. However, whenever I try to change the Input Mode from Direct Input to Hiragana (or any other mode) it simply refuses to change - it stays on Direct Input. This happens for all programs, from Notepad to Microsoft Word.

In language options, "Extend support of advanced text services to all programs" is enabled (I had expected this to fix the problem - it didn't), and the language for non-Unicode programs is set to English (I had a few problems when it was set to Japanese - also, the problem persists on either setting).

I'm using Windows XP, and the input language says Japanese Input System MS-IME2002.

Any help will be greatly appreciated.
Pete D
 
Posts: 4
Joined: Sat 09.08.2007 1:57 am

RE: IME won't change input mode

Postby Gundaetiapo » Sun 11.04.2007 9:23 pm

I always switch between the two with Alt+Shift. It occasionally requires me to do a Ctrl+CapsLock seemingly at random upon a switch over.
Last edited by Gundaetiapo on Sun 11.04.2007 9:23 pm, edited 1 time in total.
Gundaetiapo
 
Posts: 527
Joined: Fri 03.30.2007 11:26 am
Location: New England
Native language: English
Gender: Male

RE: IME won't change input mode

Postby richvh » Sun 11.04.2007 9:37 pm

Does the Alt-~ shortcut do anything?
Richard VanHouten
ゆきの物語
richvh
 
Posts: 6451
Joined: Thu 09.29.2005 10:35 pm

RE: IME won't change input mode

Postby chikara » Sun 11.04.2007 9:40 pm

On my PC's at least alt+shift switches between English and Japanese. When switching to Japanese the input mode is what ever I had it last set to.

In Japanese ctrl+capslock switches to hiragana, alt+capslock switches to katakana and alt+tilde switches toggles between direct input and which ever kana input was last selected.

The OP's problem seems to be that he can switch the IME to Japanese but can not change input method from direct input either via the short cut keys of the drop down Input Mode menu.
Don't complain to me that people kick you when you're down. It's your own fault for lying there
User avatar
chikara
 
Posts: 3577
Joined: Tue 07.11.2006 10:48 pm
Location: Australia (SA)
Native language: English (Australian)
Gender: Male

RE: IME won't change input mode

Postby saraLynne » Mon 11.05.2007 1:13 am

I have a HUGE PROBLEM with Greggman's website. I used it myself when I first set up the IME and was rather put off by a few factors.

Somewhere in his instructions he turns your machine's native language into Japanese. That's why the language bar ends up written in Japanese instead of in English. Skimming over it now, I can't figure out what he does differently, but whatever it is, it's a pain in the rear.

He also has you turn off your keyboard shortcuts. Even though direct input works just like standard english layout, I still like to be able to swap back to English if I want to.

If your language bar is all in Japanese like his is, I would undo everything he had you do (remove Japanese support from windows) and follow the directions in the FAQ here at TJP. It's fewer steps and works beautifully.
Image
User avatar
saraLynne
 
Posts: 349
Joined: Wed 07.05.2006 3:02 am

RE: IME won't change input mode

Postby Wakannai » Mon 11.05.2007 1:56 am

sometimes the only way I can switch modes is to alt-caps lock into katakana then ctrl-caps lock into hiragana mode.
Wakannai
 
Posts: 658
Joined: Thu 10.18.2007 6:38 am

RE: IME won't change input mode

Postby Pete D » Sat 11.10.2007 6:53 pm

The keyboard shortcuts to jump to the kanas wouldn't work either. I tried to reinstall the IME, but that didn't fix it. I'm putting it down to a bad install for now (since after some investigation I saw the dictionary list under the Conversion tab had repeated "Invalid System Dictionary" for files that I could verify were there) and using the Ajax IME until I can find something else.
Pete D
 
Posts: 4
Joined: Sat 09.08.2007 1:57 am

Re: IME won't change input mode

Postby lamuness » Thu 06.10.2010 7:28 am

I had to necro this thread because I just started getting this problem. I've been using the Japanese IME since the beginning of time, and I have no idea what the heck just happened. I'm running Windows 7, and now when I go into a window like firefox or notepad or something other than the windows desktop, I cannot change the input mode. It stays on the "A Input mode". Ctrl / Alt + caps lock does nothing. I can't even click on that button.

Does anyone know of a fix for this? Google is not helping at all.

Thanks a lot.
lamuness
 
Posts: 1
Joined: Thu 06.10.2010 7:23 am
Native language: English

Re: IME won't change input mode

Postby phreadom » Thu 06.10.2010 7:38 am

As Rich said;
richvh wrote:Does the Alt-~ shortcut do anything?


?

That's what I use to switch between Latin "A" and Hiragana "あ" etc.
猿も木から落ちる
User avatar
phreadom
Site Admin
 
Posts: 1761
Joined: Sun 01.29.2006 8:43 pm
Location: Michigan, USA
Native language: U.S. English (米語)
Gender: Male

Re: IME won't change input mode

Postby Cyborg Ninja » Mon 07.12.2010 7:13 pm

Since Windows 7 is so new, there could be problems with IME compatibility. Microsoft puts out really good documentation for its applications and there may be a known issue with the IME.

I use Vista and for my IME, I can right-click on the IME button next to the system tray and select "Settings." Then I can change the hotkeys (like a shortcut) for switching between languages. However, I don't know how to switch between different inputs for a language within itself, such as Japanese, but it may be there.

Consider undocking the IME by choosing "show additional icons..." or "restore the language bar," or going through the Settings.
User avatar
Cyborg Ninja
 
Posts: 122
Joined: Tue 08.29.2006 8:16 pm

Re: IME won't change input mode

Postby syd » Tue 11.13.2012 2:40 pm

I have just installed Windows8 and Windows Live mail.
I have no problem typing English but when switch to Microsoft IME, I can't type Japanese only in Windows Live Mail, but any other software like Word, Excel....
I didn't have this problem with Windows 7. :think:
Is there any body having the same problem and how did you fix this problem?

Thanks in advance
Syd
syd
 
Posts: 1
Joined: Tue 11.13.2012 2:31 pm
Native language: Japanese


Return to Japanese General Discussion

Who is online

Users browsing this forum: No registered users and 4 guests