Duplicating the autolog issue

Spotted any errors or found anything that doesn't work?
Post Reply
Wakannai
Posts: 658
Joined: Thu 10.18.2007 6:38 am

Duplicating the autolog issue

Post by Wakannai » Sun 03.09.2008 9:44 am

Ok, I thought a separate thread here might be more useful than a bunch of shouts.

This is my issue and why it might not duplicate quickly.

First, I never noticed the login at the bottom of the page, so I used the new post workaround. Only after someone shouted about it did I look all the way at the bottom. I suggest moving it to the top.

So since that login thing is there, I won't go into the new topic workaround anymore. However, there still seems to be an auto-log issue.

Since Clay is trying to duplicate it. This is what seems to be the schedule of events.
1. Login to thejapanesepage. The cookie for my previous login seems to be valid. So I'm autologged into thejapanesepage. But when I click Forum. I am not autologged in.

I can get the auto-log feature to work temporarily by
a. Logging out of thejapanesepage then relogging in.
b. logging in at the bottom of the forums.
Then even if I shut the client down, It will still log me into the forums automatically. After I visit thejapanesepage and click on the forum link. For a little while. However, if I go out to eat, by the time I come back and try to login to the forum, it will not autolog me in. So I suspect it is a timestamp issue. Thejapanesepage will accept a cookie that is days old, but the forums will only accept a cookie that is a few minutes old. It could be something else too, but that's the most likely culprit based on what I know.

User avatar
sei
Posts: 525
Joined: Fri 03.30.2007 3:34 pm
Native language: Portuguese
Gender: Female
Location: Portugal

Re: Duplicating the autolog issue

Post by sei » Sun 03.09.2008 11:24 am

So when you log out and relog into the thejapanesepage, and then enter the forums, you have to still log into the forums (by that thing at the bottom of the page)?

My problem is the same as yours, but I don't need to log into the forums if I log out and then log back into thejapanesepage. It logs me automatically for awhile and then when it stops I just have to log out and relog into thejapanesepage. I never need to log into the forums.

Though I have tried to not relog into the site and instead log in here by using the log in thing at the bottom of the page, and I can log through there.

So what works for me is:

1) Log out and relog into the main site (thejapanesepage)

2) Log in at the bottom of the page in the forums.

Edit: Sorry if I'm confusing something. I just re-read your post and you might be meaning to say the same thing I did. I was confused. Guess you can see that from my first question.
Image
Questions? Feel free to ask. :)

User avatar
clay
Site Admin
Posts: 2811
Joined: Fri 01.21.2005 9:39 am
Location: Florida
Contact:

Re: Duplicating the autolog issue

Post by clay » Sun 03.09.2008 4:16 pm

Thejapanesepage will accept a cookie that is days old, but the forums will only accept a cookie that is a few minutes old.


That would make sense. I'll definitely have the developer take a look at that and make sure they are the same.

It may be a few days, though. He has his plate full right now.
TheJapanShop.com- Japanese language learning materials
Checkout our iPhone apps: TheJapanesePage.com/iPhone

Post Reply