Learn Japanese with JapanesePod101.com

View topic - Navigation problem with Beginner Lessons

Navigation problem with Beginner Lessons

Spotted any errors or found anything that doesn't work?

Navigation problem with Beginner Lessons

Postby Snowflake » Mon 04.28.2008 9:45 am

This has been happening for the last few days. I'm sorry I don't remember the exact date when I first noticed the problem. Anyway, here is a description:

    1) Access the homepage for The Japanese Page (no problem)

    2) Click on Lessons on that greyish/black bar directly beneath the heading banner (no problem)

    3) This brings up a new page (newly redesigned sometime in the last week or so) which has several sub-heading buttons for the different types of Lessons (Beginner, Grammar, Culture, etc). This page also contains a banner at the near-top which has the names of all those same sub-headings (no problem)

    4) Click on the Beginner button (problem). Rather than bringing up the Beginner lessons, it goes to Page Not Found :(.

The workaround for this problem is to click on the word "Beginner" on the banner. That takes one to the Beginner Lessons page.

It appears that it is only the Beginner button which is faulty. Other buttons seem to work as intended. I also do not know if this is just a problem for me or if it is universal. Extra info: it appears that the problem doesn't occur once I have accessed the Beginner's page via the banner and then go back and use the button provided I don't close the browser. If I close and then reopen my browser, the problem crops up again (button doesn't work)

The problem is just a minor, minor annoyance for me (because I figured out how to work around it), but I imagine it might be more of an issue for someone brand new to the site, especially if they are also brand new to (and perhaps already a bit intimidated by) the prospect of learning a new language.

I'm sorry for making this post so long. When I describe a problem, I like to include as many details as I can to make it easier for someone to troubleshoot.
Snowflake
 
Posts: 201
Joined: Thu 01.24.2008 7:04 pm
Location: New England, USA
Native language: English

Re: Navigation problem with Beginner Lessons

Postby clay » Mon 04.28.2008 11:18 am

Thanks! I'll fix that right away. In addition to the new designs (still working on that) we totally redid the directory structure to make it more intuitive. This of course caused a few links to break.

EDIT: Hmmmm... The picture is linked correctly to http://www.thejapanesepage.com/beginners (I clicked on the picture with a map of Japan above 'Beginner Information' on this page: http://www.thejapanesepage.com/lessons). That was linked incorrectly last Friday, but was corrected. Is that the page you are referring to? If so, I wonder if it is your browser's cache remembering the incorrect link?

Or if it is a different page, please include the link.

Thanks!
TheJapanShop.com- Japanese language learning materials
Checkout our iPhone apps: TheJapanesePage.com/iPhone
User avatar
clay
Site Admin
 
Posts: 2809
Joined: Fri 01.21.2005 9:39 am
Location: Florida

Re: Navigation problem with Beginner Lessons

Postby phreadom » Mon 04.28.2008 11:32 am

Fixed.

The top banner was pointing to "beginners" instead of "/beginners" as the link. So it was trying to go to "/node/beginners", which doesn't exist.

For the record, there is no "/lessons/beginners" either... Maybe that's the root of the problem. :) It looks like you set the rest of the links up to work as /lessons/name, but there isn't such a link for the beginners level.
猿も木から落ちる
User avatar
phreadom
Site Admin
 
Posts: 1761
Joined: Sun 01.29.2006 8:43 pm
Location: Michigan, USA
Native language: U.S. English (米語)
Gender: Male

Re: Navigation problem with Beginner Lessons

Postby Snowflake » Mon 04.28.2008 12:30 pm

Thank you, Clayさん and Phreadomさん! It all seems to be fixed now.

To answer your question, Clayさん, yes, I was trying to go to this page ---> http://www.thejapanesepage.com/beginners by clicking on the first button (with the map of Japan on it) on this page ---> http://www.thejapanesepage.com/node/18. I was getting a Page Not Found error. It works properly now. Hooray!

As a side note, going back to this page ---> http://www.thejapanesepage.com/beginners, I noticed on the blue sub-banner (the one under the grey-black general banner) there is a notation that says "General Lessons" but there is no corresponding button in the body of the page. That's too bad, because when I clicked on the banner text General Lessons, it took me to a wonderful section with information on telling time and time durations. My Conversational Japanese class just went over this material (I stink at telling time, by the way), so this module is of particular value to me.

Button it up when you get a chance, please :D !

ありがとう!
Snowflake
 
Posts: 201
Joined: Thu 01.24.2008 7:04 pm
Location: New England, USA
Native language: English

Re: Navigation problem with Beginner Lessons

Postby clay » Mon 04.28.2008 3:13 pm

Thanks! I'll work on that and add more to the 'general lessons' category.

Thanks for spotting that.

For the record, there is no "/lessons/beginners" either... Maybe that's the root of the problem. :) It looks like you set the rest of the links up to work as /lessons/name, but there isn't such a link for the beginners level.


Yeah, there was a reason why I didn't include /lessons/ at the time. But now... I can't remember why. Maybe I had already linked to /beginners/ and didn't want to go back and fix links. (Lazy)
TheJapanShop.com- Japanese language learning materials
Checkout our iPhone apps: TheJapanesePage.com/iPhone
User avatar
clay
Site Admin
 
Posts: 2809
Joined: Fri 01.21.2005 9:39 am
Location: Florida


Return to Problems

Who is online

Users browsing this forum: No registered users and 4 guests

cron