Learn Japanese with JapanesePod101.com

View topic - Website feedback needed!

Website feedback needed!

NO SPAM ALLOWED! Discuss stuff not related to Japan or Japanese. The rules are the same in this forum as in the other forums.

Website feedback needed!

Postby keatonatron » Fri 09.11.2009 1:27 pm

Hello everyone,

I know we have a lot of tough critics here, which is why I've decided to submit my latest creation to your scrutiny. :P

I have spent the past few days designing a new personal website to showcase videos I've made and to act as an online calling-card. I now need feedback/quality reports!

Feedback includes what you think of the site's layout, color scheme, ease of use, etc. Quality includes how fast it loads, whether or not all the images appear, etc.

I plan to add more videos in the future. Right now, there is only one (detroit7). I am trying to decide whether to do the video-hosting myself, or to put all the videos on a public server (like vimeo) and embed them in my page. The video I have up now is only 30 mb (about half the size of videos on facebook, which play perfectly!), but it seems to load quite slowly. I think my hosting provider is not very good... at least not from over here. That's why I'd like to hear how well it loads for people from various locations.

Also, layout-wise, I will be adding more text and perhaps moving around the video thumbnails (which will also increase). I'm conflicted about the box to the right of the video player; I'm thinking I could put the thumbnails down below and have the box change with the video to display information, or move all the thumbnails up into the box. You'll see what I mean when you get there! I think having the thumbnails down below would give a more organic feel, while having them up top would be more boxy.

So for anyone who is interested, please check out my site and tell me:
1. Your location, how fast the site loads, and how fast the video loads once you click on the "video" link or the far right video thumbnail.
2. If there are any parts that don't work for you (images that don't load, borders that don't line up, etc.). If you have any major problems, letting me know what browser you are using would also be helpful!
3. Your opinions on the overall layout of the whole site. Specific information is most helpful; why do you or don't you like a certain element/color?

And last but not least... the secret link!

Edit: The site is now live:
www.jmacwhyte.com

Thanks for your help! Be brutal :D
User avatar
keatonatron
 
Posts: 4838
Joined: Sat 02.04.2006 3:31 am
Location: Tokyo (Via Seattle)
Native language: English
Gender: Male

Re: Website feedback needed!

Postby NileCat » Fri 09.11.2009 2:34 pm

日本からこんにちは!

東京(光回線)
ページ読み込みは、5秒くらい
ビデオ読み込みは、30秒~45秒
IE8-J on Vista-J and Safari4-J on Mac SL-J で動作を確認
格好いいと思いました!
User avatar
NileCat
 
Posts: 1168
Joined: Sat 08.01.2009 2:11 pm
Location: Tokyo
Native language: Japanese

Re: Website feedback needed!

Postby keatonatron » Fri 09.11.2009 4:13 pm

ありがとうございます!
NileCatさんのお宅から接続が割と速いですね。
User avatar
keatonatron
 
Posts: 4838
Joined: Sat 02.04.2006 3:31 am
Location: Tokyo (Via Seattle)
Native language: English
Gender: Male

Re: Website feedback needed!

Postby AJBryant » Fri 09.11.2009 4:39 pm

I'm trapped loading up a new computer now, but I promise I'll drop by and take a look at it before Monday!!


Tony
User avatar
AJBryant
Site Admin
 
Posts: 5313
Joined: Sun 10.09.2005 11:29 am
Location: Indiana
Native language: English
Gender: Male

Re: Website feedback needed!

Postby Kakads » Fri 09.11.2009 4:40 pm

Hello!

Location: London, England, United Kingdom

Using Firefox, it took two minutes before anything actually appeared on the page, even the title of the page. The images took about one minute to load, no image in particular caused any problems. The video player loaded after at first telling me that I did not have Java enabled(Which I did), but does not play anything.

Same with Google Chrome.
Same with IE8.

My internet is generally quite fast, I remember downloading over 800KB/s over torrents quite a few times.

I like the layout. :)
User avatar
Kakads
 
Posts: 77
Joined: Mon 04.17.2006 7:19 am
Location: London, UK
Native language: English
Gender: Male

Re: Website feedback needed!

Postby phreadom » Fri 09.11.2009 5:04 pm

The kana/kanji are practically invisible on my monitor... and the video still isn't doing anything. Doesn't even appear to be loading? :(

Otherwise it looks a little grunge/scene/goth. ;) scary letters, dark colors, and plaid. :P
猿も木から落ちる
User avatar
phreadom
Site Admin
 
Posts: 1762
Joined: Sun 01.29.2006 8:43 pm
Location: Michigan, USA
Native language: U.S. English (米語)
Gender: Male

Re: Website feedback needed!

Postby keatonatron » Fri 09.11.2009 5:13 pm

Just to confirm, did you guys click on one of the video links? They player doesn't do anything when the page first loads, you have to choose something to watch first (there is only one option at the moment...) As long as you can see the player, it will give you feedback as to what it is doing (if it is loading, there will be a spinning circle in the middle. If it can't find the file to load, it will give an error. If it literally does nothing, you haven't chosen a video yet! :wink: [or... Javascript isn't working :? ])

Kakads' slow loading kind of worries me. I think the server is in the US, but if I can load it fairly quickly you should be able to as well. Do you know specifically what kind of connection you have? Could you try it again at another time of day?

phreadom wrote:Otherwise it looks a little grunge/scene/goth. ;) scary letters, dark colors, and plaid. :P


Yeah, I have to cater to the kinds of people I work with/want to work with :wink:

Trivia! The background is based off a pair of pants I have (and am wearing right now)
User avatar
keatonatron
 
Posts: 4838
Joined: Sat 02.04.2006 3:31 am
Location: Tokyo (Via Seattle)
Native language: English
Gender: Male

Re: Website feedback needed!

Postby phreadom » Fri 09.11.2009 5:27 pm

That seems really unintuitive... or I'm just stupid. ;)

Maybe you could have the video player by default load a single frame that points to the video section and says "please choose a video to view from below" or something.

As it stands, it's just a plain black empty screen on the video player that doesn't do anything even when you click on it. It doesn't seem obvious at all that you need to choose a video from down below by clicking on one of the little thumbnails to cause it to load in the viewer. :(
猿も木から落ちる
User avatar
phreadom
Site Admin
 
Posts: 1762
Joined: Sun 01.29.2006 8:43 pm
Location: Michigan, USA
Native language: U.S. English (米語)
Gender: Male

Re: Website feedback needed!

Postby keatonatron » Fri 09.11.2009 5:45 pm

phreadom wrote:Maybe you could have the video player by default load a single frame that points to the video section and says "please choose a video to view from below" or something.


That's next on the list of things to do :wink:
I also thought about having it load a show reel that has snippets from all the videos, but haven't have time to edit something like that yet. I was mainly concerned with setting up a framework that could be easily tweaked even after data has been added in.

Second on the list is to create two distinct versions of the site for English and Japanese (right now the two are mixed, and may be hard to read on some screens).

If I make all the text white, it's too overwhelming :shock: A button to simply flip the color associations would be cool :mrgreen:
User avatar
keatonatron
 
Posts: 4838
Joined: Sat 02.04.2006 3:31 am
Location: Tokyo (Via Seattle)
Native language: English
Gender: Male

Re: Website feedback needed!

Postby Kakads » Fri 09.11.2009 5:53 pm

Okay, I clicked the thumbnail and it took roughly one minute before the video started playing. It took about 10 minutes for the whole video to finish loading.

I have 5MB wireless broadband with my local ISP, Orange.

Here's my speedtest.net result if it helps any:
Image
User avatar
Kakads
 
Posts: 77
Joined: Mon 04.17.2006 7:19 am
Location: London, UK
Native language: English
Gender: Male

Re: Website feedback needed!

Postby keatonatron » Sun 09.13.2009 8:43 am

Kakads, thank you for that.

I have updated my site to use Vimeo. Their servers are awesome, so it should load much faster :P

Please check it again if you have the time and let me know how it compares. Also, if someone else from the UK could let me know how long it takes the site to load for them, I'll get an idea of if it's just Kakads' connection or all of the UK that has a slow loading time :wink:
User avatar
keatonatron
 
Posts: 4838
Joined: Sat 02.04.2006 3:31 am
Location: Tokyo (Via Seattle)
Native language: English
Gender: Male

Re: Website feedback needed!

Postby Valatunda » Sun 09.13.2009 9:36 am

I’m in Blackpool, England and using IE8.

Site loaded up in around 3 or 4 seconds and the video in around 5 minutes. (Edit: Another loading of the video was in around 3 minutes.)

Concerning other things, the dark red and grey text can be a bit difficult to see and the white has slight brightness, but isn’t terrible. Also, at the bottom the “info jmacwhyte.com” links to a page not found. With the space next to the video, I don’t have any problems with the thumbnails underneath so a description could be good.

Overall it all seems set out nicely though.
User avatar
Valatunda
 
Posts: 171
Joined: Thu 01.04.2007 6:44 am
Location: イギリス
Native language: 英語

Re: Website feedback needed!

Postby keatonatron » Sun 09.13.2009 10:30 am

Valatunda wrote:Also, at the bottom the “info jmacwhyte.com” links to a page not found.


I think I was working on it as you were viewing the page. Should be fixed now (utilizing nifty Javascript so spam bots don't steal my info!)

the white has slight brightness


Sitting in a dark room, are ya? That text is the same color as the white on this page :lol:

I'll experiment with some other shades.
User avatar
keatonatron
 
Posts: 4838
Joined: Sat 02.04.2006 3:31 am
Location: Tokyo (Via Seattle)
Native language: English
Gender: Male

Re: Website feedback needed!

Postby Kakads » Sun 09.13.2009 5:04 pm

Okay, tried it again:

Site loaded in about 3 seconds, video fully loaded in under a minute.
I hope that helps.
User avatar
Kakads
 
Posts: 77
Joined: Mon 04.17.2006 7:19 am
Location: London, UK
Native language: English
Gender: Male

Re: Website feedback needed!

Postby keatonatron » Sun 09.13.2009 6:05 pm

Wow, that's a big improvement. I'm relieved. Thanks for keeping me updated!
User avatar
keatonatron
 
Posts: 4838
Joined: Sat 02.04.2006 3:31 am
Location: Tokyo (Via Seattle)
Native language: English
Gender: Male

Next

Return to General off topic

Who is online

Users browsing this forum: No registered users and 4 guests