Learn Japanese with JapanesePod101.com

View topic - Gaim

Gaim

Spotted any errors or found anything that doesn't work?

Gaim

Postby Infidel » Tue 07.04.2006 11:57 pm

Is there a way to increase the size of the fonts in GAIM? Everything is tiny, like 7pt. I can hardly read it.

I followed the directions here http://www.thejapanesepage.com/jabberchat/gaimfont.html

And they had absolutely no effect.

Please help me. The other chat clients crash my computer at work, so are off limits. But I can't read anything in GAIM.
なるほど。
さっぱりわからん。
User avatar
Infidel
 
Posts: 3093
Joined: Sun 10.09.2005 1:12 am
Native language: 英語

RE: Gaim

Postby Harisenbon » Wed 07.05.2006 12:34 am

If you've changed the default GAIM fonts, make sure that your settings are set to override other people's styles in the chat window.

Tool>Options>Third Item down
"Turn on styles received from other parties" or something like that. The Japanese version says:
受信したメッセージの書式を有効にして侮ヲする(F)

Gaim is kind of finiky with the fonts, and I'm still trying to get it to stop displaying everything in sans serif.
User avatar
Harisenbon
 
Posts: 2964
Joined: Tue 06.14.2005 3:24 am
Location: Gifu, Japan
Native language: (poor) English

RE: Gaim

Postby zengargoyle » Wed 07.05.2006 1:22 am

i guess it depends on which version of Gaim you're using.

on my version:
Tools->Preferences->Interface->Conversations->Message Text:
select 'Ignore font faces' and 'Ignore font sizes'.

this should stop Gaim from trying to use whatever font junk the other person is trying to send and use your defaults instead.

second thing to check. on the gaimfont page you're told to edit the gaimrc file. search your computer and make sure you're editing the correct file. you may have accidentally installed a couple different versions of GTK (the toolkit used by Gaim) somehow.

third thing to check. Windows has this horiibly nasty habit of adding a '.txt' extension to files that you edit with Notepad/Wordpad, and then it hides the extension from you so you never see it. grrrr. go to the View Folder options for explorer and find the 'hide known extensions' checkbox and make sure it's not selected. then make sure the 'gtkrc' file didn't accidentally get a '.txt' added to its name. if it did, remove the '.txt' part.

for the way advanced font selection/manipulation (if you want to deal with it...) (for Harisenbon-san, this mission should you choose to accept it....)

GTK uses a font library that is common on Linux called fontconfig. somewhere in the GTK installation is a file called something like 'fonts.conf' or 'fontconfig.conf' or 'local.conf', this is an XML file where you can do all sorts of font selection magic, like turning any request for 'sans-serif' into a request for 'serif', or setting a list of fonts that you want to be used when a program requests 'serif'. if you know the fonts on your machine, and what you want to do, you can probably make it happen. for instance, this will turn sans into serif:

<match target="pattern">
<test qual="any" name="family">
<string>sans</string>
</test>
<edit name="family" mode="assign">
<string>serif</string>
</edit>
</match>

and this will make serif choose characters from the first font that has the characer:

<alias>
<family>serif</family>
<prefer>
<family>Bitstream Vera Serif</family>
<family>Times New Roman</family>
<family>Nimbus Roman No9 L</family>
<family>Luxi Serif</family>
<family>Times</family>
<family>Kochi Mincho</family>
<family>AR PL SungtiL GB</family>
<family>AR PL Mingti2L Big5</family>
<family>Baekmuk Batang</family>
</prefer>
</alias>

so, if that isn't horribly confusing, look for the font config file, and maybe google for how to configure fontconfig and you can get Gaim to do your bidding....
User avatar
zengargoyle
 
Posts: 1200
Joined: Sun 05.29.2005 10:16 pm

RE: Gaim

Postby saraLynne » Wed 07.05.2006 3:04 am

Plugin that gives you an interface to change font sizes in the buddy list, main screen, etc.

http://sourceforge.net/projects/gaim-extprefs/
User avatar
saraLynne
 
Posts: 349
Joined: Wed 07.05.2006 3:02 am

RE: Gaim

Postby Infidel » Wed 07.05.2006 5:59 am

thanks, It turns out it was a conflict set up by when I followed some directions to make IME permanently on by going into system and setting up a GTK entry. When I deleted that entry everything worked.

Thanks.

Rykk
なるほど。
さっぱりわからん。
User avatar
Infidel
 
Posts: 3093
Joined: Sun 10.09.2005 1:12 am
Native language: 英語


Return to Problems

Who is online

Users browsing this forum: No registered users and 1 guest