Learn Japanese with JapanesePod101.com

View topic - WagaWiki : Table / html code problem.

WagaWiki : Table / html code problem.

Spotted any errors or found anything that doesn't work?

WagaWiki : Table / html code problem.

Postby paul_b » Sun 08.20.2006 4:54 am

First I should point out that this is not a problem with WagaWiki, just one table of content.

Knumon added a table of counters to the page I'd written. here. However the Japanese text had all been changed to &# 1234; style form which is
a darn pain when editing.

Now I didn't want to have to retype it so I did a little fiddling around and came
up with this that I think looks quite nice even if I do say so myself. The problem is that it is stuffed full of HTML Junk left over by MS Word. >_<;

Anybody know an easy way to tidy it up without losing the Japanese text? Or does anybody know an easy way to turn the Japanese &# 1234; stuff into normal unicode text (as used in the rest of the page)?
Last edited by paul_b on Sun 08.20.2006 4:55 am, edited 1 time in total.
User avatar
paul_b
 
Posts: 3210
Joined: Thu 06.01.2006 9:35 am

RE: WagaWiki : Table / html code problem.

Postby paul_b » Sun 08.20.2006 5:49 am

paul_b wrote:
Or does anybody know an easy way to turn the Japanese &# 1234; stuff into normal unicode text (as used in the rest of the page)?


I guess Zengargoyle knows.

Yay for Zengargoyle!
User avatar
paul_b
 
Posts: 3210
Joined: Thu 06.01.2006 9:35 am

RE: WagaWiki : Table / html code problem.

Postby zengargoyle » Sun 08.20.2006 5:50 am

perl -pe 's/&#(\d+);/chr($1)/ge' < bad.wiki.txt > good.wiki.txt

also removed all of the totally evil microsloth stuff.

please, please, please... no microsloth stuff. no HTML Entities (&#dddd;) stuff.
it's horribly horribly evil.
it breaks the history diffs.
evil! evil! evil! evil!
User avatar
zengargoyle
 
Posts: 1200
Joined: Sun 05.29.2005 10:16 pm

RE: WagaWiki : Table / html code problem.

Postby paul_b » Sun 08.20.2006 6:04 am

zengargoyle wrote:
please, please, please... no microsloth stuff. no HTML Entities (&#dddd;) stuff.

I only ended up with one trying to fix the other. :-/
User avatar
paul_b
 
Posts: 3210
Joined: Thu 06.01.2006 9:35 am

RE: WagaWiki : Table / html code problem.

Postby zengargoyle » Sun 08.20.2006 6:25 am

nah, there was horrible evil microsloth stuff in the first edition with the HTML Entities.
full of {font} and {span} and {br} tags for every table element. using {b} and {i} instead of {th} tags, putting {p} tags around everything. ewwww gross.. :)
User avatar
zengargoyle
 
Posts: 1200
Joined: Sun 05.29.2005 10:16 pm

RE: WagaWiki : Table / html code problem.

Postby paul_b » Sun 08.20.2006 6:29 am

I'm terribly out of date on html, and never really used Wiki in the first place. :(
User avatar
paul_b
 
Posts: 3210
Joined: Thu 06.01.2006 9:35 am

RE: WagaWiki : Table / html code problem.

Postby coco » Wed 08.23.2006 6:00 am

ここに便乗させてもらいます。m(_)m
wikiの時間管理はUTCを基準にしているのですよね。
だとすると署名の時間もUTCの方が分かりやすくありませんか?
今のままだとアメリカ東部時間とUTCが混在しているように思いますが、勘違いかな。。
coco
 
Posts: 3061
Joined: Mon 05.30.2005 12:43 am
Location: 東京都
Native language: 日本語(Japanese)


Return to Problems

Who is online

Users browsing this forum: No registered users and 6 guests